MWD Software Datasheet

Applied Physics | Detect

Systems
Features Applications
e Configure inputs to and outputs from Detect. e Configure Model AP250 EM MWD Systems
e Collect and display unfiltered, live bit run data from the EM dipole. e Interfaces with Applied Physics Systems Virtual Drill Software
e Save bit run data to a file. - Detect sends bit run data from the sensor to Virtual Drill
e Playback previously recorded bit run data. e Import custom packet files created using Applied Physics Systems
e Display parity and checksum errors. Configuration Utility Software

e Transmit WITS parameters to any WITS-compatible program.
* Monitor incoming data parameters to confirm they are within preset limits. Supported Devices
* Monitor and send qualified survey data over WITS. o Applied Physics Systems EM Dipole
e Send downlink commands to the EM dipole while it is downhole.
e (Change the packets the dipole sends using custom packets.
e Establish communications with depth tracking hardware and/or third
party software.

e Print reports with bit run settings.

Detect is part of the Applied Physics Systems Software Suite, which includes:

e Configuration Utility e Depth Tracker e *Detect
e Directional Sensor Configuration Utility e Firmware Update Sensor e Firmware Update Utility
e |og Viewer e Universal Roll Test e Virtual Drill

*For more information about Detect Software, see Detect Help.

Detect supports EM Dipole, Near Bit, Shock and Vibration, and custom data packets.

Near Bit Data Packets Shock and Vibration Data Packets
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Found a Packet 19-Mov-2014 1547:10
Packet 9 (9), Mag Dec=+0.00 Degrees
TF Type G, TFO=0.00

MearBit Status: 8 (Hex)

NearBit Gamma Rotating: Yes

NearBit Gamma Sending: Yes

MearBit 0x16: Receiving

NearBit 0x17: Recaiving
Uncorrected TF = 135 Degrees
Toclface = 135 Degrees (Hex: 18)
Gamma = 36 CPS (Hex: 24)

Near Bit Gamma Transverse Shock (Peak): 6.0g gees (Hef®
Near Bit Gamma Axial Shock (Peak) =150.0g gees (Hex: 35
Uncorrectad TF = 135 Dagrees
Toclface = 135 Degreas (Hax: 18) '
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Found a Packet 19-Nov-2014 15:52:35

&
-
-
Packet 8 (8), Mag Dec=+0.00 Degrees -
TF Type M, TFO=0.00 >
Local Shock(5 bit) = 31 gees (Hex: 1F)

Local Shock(8 bit) Transverse (Peak) = 20 gees (Hex: C) o
Local Shock(8 bit) Axal (Peak) = 10 gees (Hex: 6) r
Local Shock = 40 Gees

Magnetic Blind Spot = No ¢
Checksum Calc T8 Rx 6E Met 83

Hz:8.9997 5:3019.65mV N:137.966 S5:N 22 ’

-~y Ny .ty

4
2008-New-15 15:53:0% EFDM Poei Closed ‘MQ.BH.IEIH'.'CI-P Esdl Totstl Parsr 0
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A variety of configuration and bit run functions can be accessed through Detect’s menus.

Some of the menu items can also be accessed using the icons.

File Menu

Configure Detect

Configures inputs to and outputs from Detect.

Configure Downlink

Configures the downlink for transmitting commands to the EM
dipole when the string is downhole.

Configure WTIS

Filters gamma data before it is output to a third party system.

Select Custom Packet File

Selects a custom packet file previously created in Configuration Utility.

Send 574 Downlink Setup

Sends a setup command string to the 574 Downlink Transmitter.

Print Detect Settings Prints a preformatted report displaying Detect settings.
Exit Exits Detect software.
Execution Menu | Go Collects data from the EM dipole and displays it on the main screen.
Toolbar Enables or disables displaying the toolbar icon and messages at the top of the main
screen.
Status Bar Enables or disables displaying the status bar at the bottom of the main screen.
WITS Traffic Window View WITS traffic with live data or from a playback file.
View Menu _ : View live or playback data to see when values are not within operator defined
Display Quality Measurements
ranges.
Display Survey Window Allows the operator to review survey data before it is sent over WITS.
Wave View Displays the waveform of live data or data from a playback file.
Reset Error Totals Resets the packet tally totals, at the bottom of the main screen, to zero.
About Displays the software version and contact information.
Help Menu
Detect Help Displays the help file.
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Icons
A variety of configuration and bit run functions can be accessed through Detect’s icons.

Functions for all icons can also be accessed through the menus, except for Playback Unfiltered Data and Stop Scrolling Log.

l-El Go Same as Execution > Go on the menu.
Configure Detect Same as File > Configure Detect on the menu.
Print Detect Settings Same as File > Print Detect Settings on the menu.
J
About Same as Help > About on the menu.

) Plays back a binary data file from a previous bit run.
Playback Unfiltered Data _ o _
This function is not listed on the menu.

Configure Downlink Same as File > Configure Downlink on the menu.

The toggle button starts and stops log scrolling on the main screen.
Stop Scrolling Log Data logging continues even when scrolling has stopped.
This function is not listed on the menu.

Select Custom Packet File Same as File > Select Custom Packets File on the menu.

ERIE B K X NN
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Detect Main Screen

The Detect Main Screen consists of the following to access configuration and bit run functions:

Menu Bar - The menu bar consists of the file, execution, view, and help menus.

Toolbar Icons - The functions for most toolbar icons can also be executed through the menus.

Toolbar Messages (MWD Offsets) - Toolbar messages display some of the MWD offsets previously entered in Detect.
Messages are displayed on the main screen without units.

Displaying the toolbar icons and toolbar messages is optional.

Display Area - The display area shows live data being collected, data being played back, and informational and error messages.

Status Bar - The status bar displays information at the bottom of the main screen.
Displaying the status bar is optional.

The display area (below) shows live data being collected.

 Detect L=
File Execution View Help

| /&S[®?] »| #|[® = TFO=0.00, Mdec=0.00, IPF=1.00, GtoBit=0.00, DtoBit=0.00

I

Found a Packet 19-Nov-2014 15:52:35

Packet 8 (8), Mag Dec=+0.00 Degrees

TF Type M, TFO=0.00

Local Shock(5 bit) = 31 gees (Hex: 1F)

Local Shock(8 bit) Transverse (Peak) = 20 gees (Hex: C)
Local Shock(8 bit) Axial (Peak) = 10 gees (Hex: 6)

Local Shock = 40 Gees

Magnetic Blind Spot = No

Checksum Calc 78 Rx 6E Net 83
Hz:8.9997,5:3019.65mV N:137.966 S:N 22

-

£l |__ . 1] ) ¥
2014-MNov-1915:53:05 |RFDM Port Closed Freq: 9 Hz Enc: CHP  |Bad:l Totall ParEm: 0 i

250-9904-02-0215 Page 4 of 10

www.appliedphysics.com

281 East Java Drive, Sunnyvale, CA 94089 USA ¢ 650.965.0500 ¢ Fax:650.965.0404 * email: service@appliedphysics.com




MWD Software Datasheet

Applied Physics | Detect
Systems

Configure Detect

Use Configure Detect to configure communication with the EM dipole and manage how Detect communicates with peripherals.

The Configure Detect screen contains nine configurable regions.
NI-DAQ Device Selection  Encoding Mode  Additional Displays
Log Files WITS Rig Floor Display Module
MWD Offsets Units Steerable Bit Qutput

Note: The only recommended default for Detect is Chirp for the Encoding Mode.

NI-DAQ Device Selection

Device Name: [Devi: =] [ Refresh
Standard Encoding 0ld Encoding
M use Chirp (Default) [ Use Error Correction |9 vl Hz 9 | Hz

Additscnal Displays
W Display Quality Measurements M Display Survey Confirmation Windaw

Log Files
F ]C:\Pronram Files (xB6)\Apphed Physics Systems'Detect 6.2.14 \Dete we | W append

W uUnfitered Dot | C:\Program Files (xB6]\Applied Physics Systems\Detect 6.8.18WoFl ... | 7 apoend

bl Rig Floor Display Madule
W Use WITS Protocol WITS Codes | ¥ Use Rig Floor Display Module COM Port [4 =
¥ Use COM Port ™ Use 2nd Port Refresh Rate (s): [+ i
LOM Ports |1 =] 2nd Port: |2 =] | ~MWD Offsets
© Usa TCRIP Magnetic Dechnaton (*): 5.00
| i L ! Toollace Offset (*): 0.00
Update Time () |3 Gamma IFf Correction: 1.00
™ Send Gamma T Send Gild Gamma Gamma to Bt (m): B00
W Send Inc, Az I Store Raw WITS :
I™ Send Oid Inc, Az ™ Send Annular Pressure EhECOn 0 M AL 000
™ Send Vectors ™ Send Bore Prassure True Vertical Depth (m): o.00

W Send Temperature Mud Weight (kg/m=3): |I:I.I:II:I

W Send Only On Boltam Gamma
Unsts

= | 0.10
Maoamum Off Bottom Amount (m): Pressure: © psi 5 bar © kPa Temperature:
Depth Send (s) E L2 Weights and Measures: L =
* Metric " Imparisl L

M Show WITS Traffic W Send When Bad Panty Srearabla Bit Out
W wait for Pason Reply ¥ Send Near Bit Data ™ Use Steerable Bit COM Port: (5
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Configure Downlink
Use Configure Downlink to send commands to the EM dipole to change its configuration while it's downhole during a bit run.

Note: The 574 Downlink Transmitter is optional equipment. Configuring the downlink is optional, because it may not be necessary to change
the dipole configuration during a bit run.

e Use Standard Commands to send a downlink command with multiple effects to the EM dipole.

e Use Special Commands to send a downlink command with a single effect to the EM dipole.

The example below shows a special command.

P ™
oot

¥ Uze Downlink COM Port

Port: II:DM 3 vI . .
[~ Enable Direct Downlink

Rig Code |1 1-16

" sStandard Commands & Special Cumma@

—New Dipaole Canfiguration

M Eattery Behavior (B

— Disable Downlink After Rotation (DAR OFF)
Dizable Gamma Reset (GRD OFF)

Disable Near Bit Reset (NRD OFF)

Enable Downlink After Rotation (DAR 1)

£ | Enable Downlink After Rotation & Surveys (DAR 2)
Enable Wake on Rotation (WSR ON)
Encoding Maode (CDE)

Gamma Prescale (GS)

Famma Prescale Mearbit (GSN)

Minimum Rotation Rate (RM)

Mear Bit Enable (SET NBE ON)

Mear Bit Disable (SET NBE OFF)

Mear Bit Listen (MBL)

Mear Bit Mode (NBM)

Packet 3 repeat count (QRS)
Muiat Sureew Samnla fORSY

|o=AuTO |

ALITC
1=BAT1
Send2=BAT2
3=B0OTH

Ok | Cancel |
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View Menu: WITS Traffic Windows
Use WITS Traffic Window to view the WITS traffic with live data or from a playback file.

e A pop-up window displays WITS traffic.

e Use the scroll bar on the right to scroll the data.

e The top window displays raw WITS data.

e The bottom window displays interpreted WITS data.

| 153000 G2 4558 1829899999 -
01-15-5070 024848 @ 1920-6009 09
01-15-3000 0o 4855  1030-0900 99
01-153090 =2 4856 | 1020-0009 0%
01-15-2000 0sE 4556 | 1821-0009.09
-15-30010 G 485E W

0153010 4855 | &R

153010 024595 - 1984PASONEDR
0=-1532010 04548 ;1108880 M
01-15-2010 024948 1110000
FE-15-2070 084856 1111000
0-1530070 s34 ESE 1115000
0F-15-3010 G548 1116000
01-153000 Q4856 1117000
153010 GE485E - 1118000
0150010 0546 - 1119000
Bi=-15-32010 024808 11230000
01-15-2010 024856 11210000
0-15-2000 QeScd& 58 ;11231000
t|]-|-1!i-i'IEI'|[I D dEsE .

WEIGHT ON BIT = = 000000 Ay
STANDMPE PRESSURE = = 0000000
PASON BITDEPTH = = B50.T 20000
HOLEDEPTH = BE0.T 200058
BLOCHHENHT = = 0 003000

RATE OF PENETRATIIN = = 0 Q00000
HOOKLOAD & & 0000000

WEIGHT ON BIT = = (L0000
STANDRPE PRESSURE = = 0000000
PASOHN BITOEPTH = = 850, T50000
HOLEDEPTH = 860 TS0000
BLOCHHENHET = = 003000

RATE OF PENETRATIIN = = 30 000000
HOQELOAD & & 0000000

WEIGHT ON BIT = = 0000000
STANDFPE PRESSURE = = Q.00D00O0
PASON BITDEPTH = = 8560 TO0000
HOLEDEPTH = BE0. TOOMND
BLOCHHENR T = = Q03000

RATE OF PENETRATON = = FR 000000
HODHLOAD = = (1000000

WEIGHT OM BIT & ® 0000000
ETAMDFIPE PRESSURE = = Q000000
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View Menu: Display Quality Measurements

Use Display Quality Measurements to view live or playback data to see when values are not within operator defined ranges.

From the Display Quality Measurements screen, you can select preset ranges or enter new ranges for the following parameters:
Magnetic Total (Gauss) Gravitational total (gees) ~ Gamma (CPS) Dip Angle (°) Toolface (°)

e Shock and vibration are represented by a range of colors, depending on their value.

e Datain the Current column stays white when it is within the specified range.

e Datain the Current column turns red when it is not within the specified range.

Shock Vibration
- Green <17 gees - Green <4 gees
|:| Yellow 17 to < 26 gees |:| Yellow 410 <6 gees
|:| Orange [ 26 to <35 gees |:| Orange 6 to <8 gees
- Red 35+ gees - Red 8+ gees
e
"/ Display Quality Measurements L=
Target Tolerance Minirmurm Current Maxirmum

Magnetic Total (Gauss) iu.a,puut_: E 1.00000 | -0.60000 0.33922 1.40000
Gravitational Total (gees) In,aunnn Io.zunnn | 0.70000 | 0.95922 "uomu
Gamma (CPS) |200.0 |200.0 | 0.0000 | 120 | §oo.0000
Dip Angle (%) |0.00000 | | 5.00000 | -5.0000 0000

Toolface () |u.|:| Eaau.u | -360.0000 360.0000

Magnetic Declination ()

Shock and Vibration (gees)
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View Menu: Display Survey Window

Use Display Survey Window to review survey data before it is sent over WITS.

From the Display Quality Survey Window screen, you can select preset ranges or enter new ranges for the following parameters:
Gamma (CPS) Dip Angle (°)

When data is not within the range, it can not be sent to WITS and the following message appears:

Magnetic Total (Gauss) Gravitational total (gees) Toolface (°)

Qualifiers have not passed. Will not send survey over WITS.

Display Survey Window appears at the end of a survey packet (type 0, 1, etc.) only when parity and CRC are correct and qualifiers are met.

Each time data is sent to WITS, the data appear in the bottom window.

The data remains even when the window is closed and reopened.

In the example below, data is within range and can be sent to WITS.

Click SEND TO WITS to send the data to WITS.

(37 Display Survey Window e
Directional Sensor{Survey) to 8t (m) [0
Inclination 0.0
Azimuth 75.0 O K
Bit Depth 0.0
Last Survey Sent

Inclination | 0.00000
aziemuth | 75.00000
Bt Depth [ 000000
Survey Depth 000000
Time | 22:54:27

Page 9 of 10

Inclination Azimuth Bt Depth  Survey Depth Burvey Time
a.0 75.8 4.0 o.0 22:54:27
o0 75.0 o0 0.0 22:54:25
a.0 780 0.0 0.0 22184219

www.appliedphysics.com
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View Menu: Wave View
Use Wave View to display the waveform of live data or data from a playback file.
e  (lick Stop to freeze the wave view.

e (Once stopped, the Start button appears.
e (lick Start to restart the wave view.

e  (lick Auto Scale to view the waveform in auto scale mode.
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